ubuntuusers.de

Titel:
certbo/Letsencrypt
Autor:
NicTheQuick
Datum:
30. April 2018 11:36
Aktionen:
Code:
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
root@server:/etc/apt/sources.list.d# add-apt-repository ppa:certbot/certbot
 This is the PPA for packages prepared by Debian Let's Encrypt Team and backported for Ubuntu(s).
 Mehr Informationen: https://launchpad.net/~certbot/+archive/ubuntu/certbot
Drücken Sie [ENTER], um fortzufahren oder Strg-c, um das Hinzufügen abzubrechen

gpg: Schlüsselbund `/tmp/tmpl7odzedr/secring.gpg' erstellt
gpg: Schlüsselbund `/tmp/tmpl7odzedr/pubring.gpg' erstellt
gpg: Schlüssel 75BCA694 von hkp-Server keyserver.ubuntu.com anfordern
gpg: /tmp/tmpl7odzedr/trustdb.gpg: trust-db erzeugt
gpg: Schlüssel 75BCA694: Öffentlicher Schlüssel "Launchpad PPA for certbot" importiert
gpg: Anzahl insgesamt bearbeiteter Schlüssel: 1
gpg:               importiert: 1  (RSA: 1)
OK

root@server:/etc/apt/sources.list.d# apt update
OK:1 http://download.virtualbox.org/virtualbox/debian xenial InRelease
OK:2 http://de.archive.ubuntu.com/ubuntu xenial InRelease
OK:3 http://ppa.launchpad.net/certbot/certbot/ubuntu xenial InRelease        
Holen:4 http://de.archive.ubuntu.com/ubuntu xenial-security InRelease [107 kB]
Holen:5 http://de.archive.ubuntu.com/ubuntu xenial-updates InRelease [109 kB]
Es wurden 216 kB in 0 s geholt (540 kB/s).                   
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Aktualisierung für 6 Pakete verfügbar. Führen Sie »apt list --upgradable« aus, um sie anzuzeigen.

root@server:/etc/apt/sources.list.d# apt install letsencrypt 
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 letsencrypt : Hängt ab von: certbot soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

root@server:/etc/apt/sources.list.d# apt install python-certbot-apache
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 python-certbot-apache : Hängt ab von: python3-certbot-apache soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

root@server:/etc/apt/sources.list.d# apt-cache policy certbot
certbot:
  Installiert:           (keine)
  Installationskandidat: 0.22.2-1+ubuntu16.04.1+certbot+1
  Versionstabelle:
     0.22.2-1+ubuntu16.04.1+certbot+1 500
        500 http://ppa.launchpad.net/certbot/certbot/ubuntu xenial/main amd64 Packages
        500 http://ppa.launchpad.net/certbot/certbot/ubuntu xenial/main i386 Packages
     0.19.0-1+ubuntu16.04.1+certbot+1 0
        100 /var/lib/dpkg/status
root@server:/etc/apt/sources.list.d# apt-cache policy python-certbot-apache
python-certbot-apache:
  Installiert:           (keine)
  Installationskandidat: 0.22.0-1+ubuntu16.04.1+certbot+2
  Versionstabelle:
     0.22.0-1+ubuntu16.04.1+certbot+2 500
        500 http://ppa.launchpad.net/certbot/certbot/ubuntu xenial/main amd64 Packages
        500 http://ppa.launchpad.net/certbot/certbot/ubuntu xenial/main i386 Packages
root@server:/etc/apt/sources.list.d# apt-cache policy letsencrypt
letsencrypt:
  Installiert:           (keine)
  Installationskandidat: 0.22.2-1+ubuntu16.04.1+certbot+1
  Versionstabelle:
     0.22.2-1+ubuntu16.04.1+certbot+1 500
        500 http://ppa.launchpad.net/certbot/certbot/ubuntu xenial/main amd64 Packages
        500 http://ppa.launchpad.net/certbot/certbot/ubuntu xenial/main i386 Packages
     0.14.1-0+certbot~xenial+1 0
        100 /var/lib/dpkg/status

=== /var/log/apt/history.log.2.gz (Auszug) ===
Start-Date: 2018-02-12  12:47:48
Commandline: apt-get dist-upgrade
Upgrade: python-augeas:amd64 (0.5.0-1, 0.5.0-1+ubuntu16.04.1+certbot+1), grub-common:amd64 (2.02~beta2-36ubuntu3.15, 2.02~beta2-36ubuntu3.16), libparted2:amd64 (3.2-15, 3.2-15ubuntu0.1), python-zope.hookable:amd64 (4.0.4-4build2, 4.0.4-4+ubuntu16.04.1+certbot+1), python-zope.interface:amd64 (4.1.3-1build1, 4.3.2-1+ubuntu16.04.1+certbot+1), grub2-common:amd64 (2.02~beta2-36ubuntu3.15, 2.02~beta2-36ubuntu3.16), resolvconf:amd64 (1.78ubuntu5, 1.78ubuntu6), grub-pc:amd64 (2.02~beta2-36ubuntu3.15, 2.02~beta2-36ubuntu3.16), libapparmor1:amd64 (2.10.95-0ubuntu2.7, 2.10.95-0ubuntu2.8), cloud-image-utils:amd64 (0.27-0ubuntu24, 0.27-0ubuntu25), grub-pc-bin:amd64 (2.02~beta2-36ubuntu3.15, 2.02~beta2-36ubuntu3.16), python-zope.component:amd64 (4.2.2-1, 4.3.0-1+ubuntu16.04.1+certbot+3), libapparmor-perl:amd64 (2.10.95-0ubuntu2.7, 2.10.95-0ubuntu2.8), parted:amd64 (3.2-15, 3.2-15ubuntu0.1), python-configobj:amd64 (5.0.6-2, 5.0.6-2+ubuntu16.04.1+certbot+1), apparmor:amd64 (2.10.95-0ubuntu2.7, 2.10.95-0ubuntu2.8)
Remove: python-certbot-apache:amd64 (0.19.0-1+ubuntu16.04.1+certbot+1)
End-Date: 2018-02-12  12:48:19

Start-Date: 2018-02-12  12:48:47
Commandline: apt-get autoremove
Remove: python-augeas:amd64 (0.5.0-1+ubuntu16.04.1+certbot+1), libaugeas0:amd64 (1.4.0-0ubuntu1.1), python-psutil:amd64 (5.0.1-1+certbot~xenial+2), python-zope.event:amd64 (4.2.0-1), python-rfc3339:amd64 (1.0-4+certbot~xenial+1), python-acme:amd64 (0.19.0-1+ubuntu16.04.1+certbot+1), python-dnspython:amd64 (1.15.0-1+certbot~xenial+1), python-requests:amd64 (2.18.1-1+ubuntu16.04.1+certbot+1), python-certbot:amd64 (0.19.0-1+ubuntu16.04.1+certbot+1), python-zope.hookable:amd64 (4.0.4-4+ubuntu16.04.1+certbot+1), python-zope.interface:amd64 (4.3.2-1+ubuntu16.04.1+certbot+1), certbot:amd64 (0.19.0-1+ubuntu16.04.1+certbot+1), augeas-lenses:amd64 (1.4.0-0ubuntu1.1), python-configargparse:amd64 (0.11.0-1+certbot~xenial+1), python-certifi:amd64 (2017.4.17-2+ubuntu16.04.1+certbot+1), python-chardet:amd64 (3.0.4-1+ubuntu16.04.1+certbot+2), python-ndg-httpsclient:amd64 (0.4.2-1+certbot~xenial+1), python-zope.component:amd64 (4.3.0-1+ubuntu16.04.1+certbot+3), python-pyicu:amd64 (1.9.2-2build1), python-parsedatetime:amd64 (2.1-3+certbot~xenial+1), python-pyasn1:amd64 (0.1.9-2+certbot~xenial+1), python-configobj:amd64 (5.0.6-2+ubuntu16.04.1+certbot+1), python-funcsigs:amd64 (0.4-2), python-dialog:amd64 (3.3.0-2+certbot~xenial+1), python-mock:amd64 (1.3.0-2.1ubuntu1), python-pbr:amd64 (1.8.0-4ubuntu1)
End-Date: 2018-02-12  12:49:00